View unanswered posts | View active topics It is currently 11 Dec 2018, 01:07



Reply to topic  [ 4 posts ] 
Bitstream 3X stops working completely after some time 
Author Message

Joined: 20 Aug 2010, 14:06
Posts: 32
Post Bitstream 3X stops working completely after some time
Hi jerome,

thanks for activating my account.

I am a Bistream 3X owner/user with Firmware 1.8 and Hardware 2.0 , I really love it so far. I am using it in Windows XP. I use it currently in User defined mode where the faders are sending Pitch Bend events on midi channels 1..8. So far so good, everything is nice, IF this would be the case all the time.

Unfortunately I experienced following strange behaviour already twice: After using Bitstream 3X for some time, like 1..2 hours it stopped sending any midi events from it. No fader events, no knob events, nothing. So it seems it is internally freezing or crashing, I do not know. The display shows all values correctly but nothing is received by Midi-Ox any more.

I tried following solution attempts:

1. Switching off Bitstream 3X, then switching on again. Result: Still not sending anything out.

2. Switching off Bitstream 3X, waiting for a longer time... somehow later it works again. Here I am not sure, maybe I also closed the other music applications which are Ableton Live and Midi-Ox inbetween.

Any ideas what could be the source of this strange behaviour, any other similar error reports maybe? Imagine if you would be in a live show situation and your controller stops working, would not be that funny. Especially if quick close and restart also do not help.


Ok, one last information about how my Bitstream 3X is connected to Windows: I use only a single USB cable, no other connections are used so far. It might be also some strange USB problem related to Windows XP, but then I am wondering why this problem appears after 1..2 hours of use and not directly at the beginning?

There should be no midi loopbacks due to bad software configuration as I disable any midi ports which I do not use. I really have activated only those ports which I am using and which have to be active.

My signal chain is as follows:

Bitstream 3X (via Wave Idea Bitream 3X and Wave Idea Bitream 3X [2])--> Midi-Ox (via Midi-Yoke)--> Ableton Live

Could it be also any firmware strangeness or can you exclude this for sure?

Thanks in advance and for the otherwise cool Bistream 3X, I wished the crossfader would be a little bigger object, but maybe it is easily possible to exchange this object, I mean the crossfaders plastic with something similar as available e.g. in Allen & Heath Xone:92 mixer.


20 Aug 2010, 18:42
Profile

Joined: 15 Oct 2001, 23:00
Posts: 687
Location: France
Post Re: Bitstream 3X stops working completely after some time
Hello there
do you have Xp services pack installed ?
As far as I remember, there was a known bug on USB MIDI on XP before service pack 2.

Also, is your bs3x connected to a USB hub ? delivering 100mA max or 500mA ?
You need to have a USB hub able to deliver 500mA if you do not plan to connect AC supply of your bs3x.

You can also try to restore to factory defaults, if the above do not solve your issue.
Jerome


24 Aug 2010, 15:33
Profile WWW

Joined: 20 Aug 2010, 14:06
Posts: 32
Post Re: Bitstream 3X stops working completely after some time
With AC cable plugged in everything works fine. I have an ASUS motherboard, and I read in other forums ASUS boards can have problems with USB powering, so this might be the source of my problem here, not the Bitstream 3X controller itself. Thanks for your help.

Still it would be great if you could write something on this topic: viewtopic.php?f=14&t=995


04 Feb 2011, 09:59
Profile

Joined: 06 Jul 2014, 09:35
Posts: 3
Post Re: Bitstream 3X stops working completely after some time
I confirm a similar type of behaviour.

Control software randomly stoppes working, and you have to manually switch 3X on&off to get it to work. I've got Gigabyte GA-X79S-UP5-WIFI motherboard, 3X is plugged directly to USB2.0 port (not 3.0 though). Bitstream3X FW is 1.8.

Also I've experienced random errors while downloading all the data from 3X (like Ā«control ** at group *** is out of rangeĀ», after it the download process stops and you have to start over again).

And saving libraries is TOTALLY impossible, resulting in immediate control software crash.


06 Jul 2014, 12:29
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software